Het beveiligen van je Wordpress site is makkelijker dan je denkt!

Wordpress is meest gebruikte content management systeem voor de bouw en het beheer van websites. Deze populariteit brengt met zich mee dat het een geliefd doel is geworden voor hackers. Ook wanneer je site geen klantgegevens of creditcard-informatie bevat, zullen er pogingen worden ondernomen om binnen te komen. Simpelweg ‘omdat het kan’ voor de hobbyist, én omdat geautomatiseerde software op duizenden Wordpress-achterdeuren tegelijk klopt.

Een succesvolle hack kan leiden tot de installatie van malware/ransomware die de pc van je websitebezoeker besmet, of je site wordt gebruikt om spam te versturen. En dit zijn slechts twee van de vele voorbeelden die het hacken voor bepaalde partijen interessant maakt.  

 

Tips en tricks om hackers het leven zuur te maken

Redenen genoeg om je van een paar tips te voorzien over hoe je je Wordpress installatie veilig houdt!

 

Hoe sterk is jouw wachtwoord?

Begin allereerst met de gebruikersgegevens die toegang geven tot Wordpress: kies altijd een sterk wachtwoord en een gebruikersnaam anders dan de standaard ‘admin’. Zo sluit je succesvol ‘hengelen naar gegevens’ uit.

 

Zorg ervoor dat je omgeving up to date is en blijft!

Hackers zien overal mogelijkheden om pagina's aan te passen via bestanden op de server. Gelukkig zijn de ontwikkelaars van Wordpress er (doorgaans) snel bij om lekken te dichten. Bij het kiezen van thema’s of plugins is het echter zaak om te onderzoeken of deze compatible zijn met je huidige Wordpress versie en up-to-date worden gehouden. Kijk ook even of je de herkomst hiervan vertrouwt, door het aantal installaties na te gaan en door de website van de ontwikkelaar van het thema of de plugin te bezoeken. 

 

Check of automatische updates handig zijn

Het up-to-date houden van je Wordpress installatie kan geheel automatisch. Wij raden je dan ook aan deze functie te activeren. Het updaten van thema’s en plugins kun je het beste handmatig doen, bij voorkeur echter niet direct na een release update van Wordpress. Soms is de compatibiliteit tussen de nieuwe Wordpress versie en je nieuwe thema of plugin nog niet optimaal, dus raden we je aan er gebruikerservaringen op na te slaan of er geen errors zijn die in een volgende release verholpen worden…

 

Installeer een speciale plugin voor de beveiliging

Er bestaan plugins die de beveiliging van Wordpress grotendeels uit handen nemen. De bekendste voorbeelden zijn Wordfence, iThemes Security en Securi. De functies in een notendop:

- Het aantal loginpogingen beperken en (in het geval van iThemes Security) het login panel verbergen.

- Bestanden van je Wordpress-installatie op de server scannen en eventuele beveiligingsproblemen melden. 

- Automatisch back-ups van je Wordpress database maken en deze naar je mailbox sturen.

- IP adressen per land, regio of afkomstig van bekende blacklists blokkeren.

- Een melding geven wanneer een bestand gewijzigd wordt binnen je installatie, of wanneer gebruikers buitengesloten worden.

- Eenvoudig de schrijfrechten op bepaalde mappen en bestanden instellen, zodat ze niet ongeoorloofd kunnen worden gewijzigd.

 

Hulp nodig

Veel instellingen kun je zelf eenvoudig toepassen, andere zijn iets bewerkelijker. Mocht je ergens tegenaan lopen bij het installeren of configureren waar je niet uitkomt, laat het ons dan weten. We staan voor je klaar! 

© 2017 Computel Standby - Alle rechten voorbehouden  |